Content

EasyEDA support exporting the schematics and PCB in Altium Designer format.

The “export to Altium” function is beta now, Please check carefully after exported the design to Altium, EasyEDA cannot guarantee that is no errors!!! EasyEDA does not bear any loss due to library errors and format conversion!!! If you do not agree, please do not carry out Altium export!!!

If you want to order the PCB please generate the Gerber instead of exporting to Altium!
Please do not export your design to Alitum and import it again and again, that will cause some details missing!!!
Doesn’t support Alitum 19 yet, please open exported file at Altium 18 and less, recommend Altium 17

If you find out some incorrect detail, please contact us to fix, including detail and files.
picture 49

When exporting, you don’t need to save document at firstly, but you need to login.

Exporting Schematics In Altium Designer Format

EasyEDA support exporting the schematics in Altium Designer format.
Via “File > Export > Altium…”, and click the “Download” you will get a .schdoc file.

picture 9

Exporting PCB in Altium Designer Format

EasyEDA support exporting the PCB in Altium Designer format.
Via “File > Export > Altium…” you will get a .pcbdoc file.

picture 10

When open the exported PCB file at Altium Designer, there will open a dialog of DXP Import Wizard, don’t worry, just cancel it to continue.

Known Issue:

  • 1. No Copper Area fill data.
    And then, you will see the PCB file, which is looks like without copper area as below:

    You need to repour all polygons at Altium Designer. Via: Tools > Polygon Pours > Repour All:

    And the last, save it.
  • 2. No Ratlines.

If you export the PCB without ratlines, you need to show all connections first before routing :
Via: Design > Netlist > Clean All Nets (D > N > A),and then (V > C > S)

Or use hotkey: N > H > A and then N > S > A:

  • 3. Inner layer Plane Zone doesn’t export perfectly.

You need to rebuild the plane zone, and re-assgin plane zone’s net.

  • 4. Doesn’t support DRC rule.

Please check the DRC manually.

  • 5. The text may be changed.

Because of the font family, some text maybe will change the position. And it maybe will display incorrect, please modify the text manually.

Exporting Footprint and Symbol in Altium Designer Format

EasyEDA don’t support to export the Symbol or Footprint as Altium Designer library format, but you can place the libraries to the schematic or PCB, and export that in Altium Designer format, and then extract the libraries at Altium Designer.

EasyEDA does not bear any loss due to library errors and format conversion!!! If you do not agree, please do not carry out Altium export!!!


goToTop